Xampp worked fine when i was using linux mint 12 . But when i upgraded to 64-bit system , i ended with problem.

The installation of xampp works fine with 64-bit system. But when you try to invoke xampp, it says

XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system.

and as usual i tried in google for this and came to know that i ve to do 2 things.

1. commenting out few portions in conf file

vi /opt/lampp/lampp
# XAMPP is currently 32 bit only
#case `uname -m` in
#    *_64)
#    if /opt/lampp/bin/php -v > /dev/null 2>&1
#    then
#        :
#    else
#        $de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
#        $de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
#        exit
#    fi
#    ;;
#esac

Write the file and quit

2.

 sudo apt-get install ia32-libs
 

please dont do this in linux mint . its an 88 mb archive. after downloading 60 mb it got struck. not able to complete the process.

Instead go for

sudo apt-get install lib32stdc++6

which will work fine.

now start xampp

/opt/lampp/lampp start

it should work fine

Advertisements

Comments are closed.